Configuring BGP service - Adaptive Applications - BlueCat Gateway - 21.2

BlueCat Distributed DDNS Administration Guide

Locale
English (United States)
Product name
BlueCat Gateway
Version
21.2

The following section guides you through the configuration of BGP for Quagga service. The routers in your network must be configured for use with BGP before using Anycast. For additional information on Quagga BGP, refer to https://www.nongnu.org/quagga/docs/docs-multi/BGP.html.

Configuring BGP service in an IPv4 environment

The following section goes through the steps required to configure the following BGP topology.



  1. Log in to the console of the service nodes to be configured with BGP.
  2. Edit the /etc/network/interfaces file.
  3. Add an Anycast virtual IP address to the host's loopback device using the following example:
    auto lo
    iface lo inet loopback
    auto lo:0
    iface lo:0 inet static
    address 14.0.0.14
    netmask 255.255.255.255
  4. Restart the network daemon using the following command:
    systemctl restart networking

    The command restarts the network service and applies the configurations to the service node.

  5. Log in to the Gateway instance that has the Distributed DDNS Application Node.
  6. Under AVAILABLE ACTIONS, click Distributed DDNS.
  7. Click the Service Points tab to access the service node page.
  8. Click Anycast service.
  9. Under the Configuration tab, select BGP.
  10. In the configuration window, enter the following information:
    !bgpd.conf
    !
    router bgp 200
    network 14.0.0.4/32
    neighbor 11.0.0.3 remote-as 200
    neighbor 11.0.0.3 update-source ens33
    !
    Where the parameters represent the following:
    • router bgp 200: Enable a BGP process with the specified Autonomous System Number (ASN). Anycast BGP requires an ASN allocated for each Autonomous System in the Anycast BGP network. Any ASNs used on the internet must be officially registered and allocated by the Internet Assigned Numbers Authority (IANA). If ASNs are only used within a corporate network and the corresponding AS has no direct connection to the internet, then ASNs must be defined within the following range for private use: 64512-65534.
    • network 14.0.0.4/32: Announces the specific network to all neighbours
    • neighbor 11.0.0.3 remote-as 200: Creates a new neighbor whose remote-as is the asn. The peer can be an IPv4 or IPv6 address.
    • neighbor 11.0.0.3 update-source ens33: Specify the IPv4 source address for use for the BGP session to this neighbour. This can be specified as either an IPv4 address directly or as an interface name (in which case the zebra daemon must be running for bgpd to be able to retrieve the interface state).
  11. Click Start to enable the BGP service.
  12. Click Save to save the BGP service configuration and add the service to the Distributed DDNS Service Node.
  13. Repeat steps 8 to 12 for the second service node, updating the ASN and IP address when updating the BGP configuration information.

Configuring BGP service in an IPv6 environment

The following section goes through the steps required to configure the following BGP topology.



  1. Log in to the console of the service nodes to be configured with BGP.
  2. Edit the /etc/network/interfaces file.
  3. Add an Anycast virtual IP address to the host's loopback device using the following example:
    auto lo
    iface lo inet loopback
    auto lo:0
    iface lo:0 inet6 static
    address 2001:200:1:f:10::1
    netmask 128
  4. Restart the network daemon using the following command:
    systemctl restart networking

    The command restarts the network service and applies the configurations to the service node.

  5. Log in to the Gateway instance that has the Distributed DDNS Application Node.
  6. Under AVAILABLE ACTIONS, click Distributed DDNS.
  7. Click the Service Points tab to access the service node page.
  8. Click Anycast service.
  9. Under the Configuration tab, select BGP.
  10. In the configuration window, enter the following information:
    !bgpd.conf
    !
    router bgp 200
    network 2001:db8:acad:a::1 remote-as 200
    !
    address-family ipv6
    network 2001:200:1:f:10::1/128
    neighbor 2001:db8:acad:a::1 active
    exit-address-family
    !
  11. Click Start to enable the BGP service.
  12. Click Save to save the BGP service configuration and add the service to the Distributed DDNS Service Node.
  13. Repeat steps 8 to 12 for the second service node, updating the ASN and IP address when updating the BGP configuration information.