Configuring BGP service - Adaptive Applications - BlueCat Gateway - 22.1

BlueCat Distributed DDNS Administration Guide

Locale
English (United States)
Product name
BlueCat Gateway
Version
22.1

The following section guides you through the configuration of BGP for Quagga service. The routers in your network must be configured for use with BGP before using Anycast. For additional information on Quagga BGP, refer to https://www.nongnu.org/quagga/docs/docs-multi/BGP.html.

Configuring BGP service in an IPv4 environment

The following section goes through the steps required to configure the following BGP topology.



  1. Log in to the Address Manager server where the DNS/DHCP Server has been deployed as a service node.
  2. Select the Servers tab.
  3. Under Servers, click the name of the DNS/DHCP Server that the service node has been deployed to.
  4. Click the server name menu button and select Service Configuration.
  5. Under the Interface column, choose the loopback (lo) interface then navigate across the row to the Action column and click Edit.
  6. Complete the following:
    • In the Description field, enter a name for the new loopback address. You can enter up to 80 alphanumeric characters including spaces, but excluding special characters.
    • In the Address/CIDR field, enter 14.0.0.14/32.
    • Click Add Address. The loopback address appears in the Addresses list.
  7. Click OK. The Edit Interfaces pop-up window closes.
  8. Log in to the Gateway instance that has the Distributed DDNS Application Node.
  9. Under AVAILABLE ACTIONS, click Distributed DDNS.
  10. Click the Service Points tab to access the service node page.
  11. Click Anycast service.
  12. Under the Configuration tab, select BGP.
  13. In the configuration window, enter the following information:
    !bgpd.conf
    !
    router bgp 200
    network 14.0.0.4/32
    neighbor 11.0.0.3 remote-as 200
    neighbor 11.0.0.3 update-source ens33
    !
    log trap informational
    log stdout
    log file /var/log/quagga/bgpd.log
    log record-priority
    !
    Where the parameters represent the following:
    • router bgp 200: Enable a BGP process with the specified Autonomous System Number (ASN). Anycast BGP requires an ASN allocated for each Autonomous System in the Anycast BGP network. Any ASNs used on the internet must be officially registered and allocated by the Internet Assigned Numbers Authority (IANA). If ASNs are only used within a corporate network and the corresponding AS has no direct connection to the internet, then ASNs must be defined within the following range for private use: 64512-65534.
    • network 14.0.0.4/32: Announces the specific network to all neighbours
    • neighbor 11.0.0.3 remote-as 200: Creates a new neighbor whose remote-as is the asn. The peer can be an IPv4 or IPv6 address.
    • neighbor 11.0.0.3 update-source ens33: Specify the IPv4 source address for use for the BGP session to this neighbour. This can be specified as either an IPv4 address directly or as an interface name (in which case the zebra daemon must be running for bgpd to be able to retrieve the interface state).
    • log trap informational: Sets the current logging level for all enabled logging destinations and sets the default logging level for all future logging commands that do not specify a level.
    • log stdout: Enable logging output to stdout.
    • log file /var/log/quagga/bgpd.log: Enable logging to a log file.
      Note: If you do not configure any file logging and the daemon crashes due to a signal or assertion failure, the service attempts to save the crash information in the /var/tmp/quagga.<daemon_name>.crashlog file. If this file already exists, the service will not save the crash information for security purposes. BlueCat recommends deleting this file after recording or saving the crash information.
    • log record-priority: Includes the severity of all messages logged to a file, stdout, or to a terminal monitor.
  14. Click Start to enable the BGP service.
  15. Click Save to save the BGP service configuration and add the service to the Distributed DDNS Service Node.
  16. Repeat steps 8 to 12 for the second service node, updating the ASN and IP address when updating the BGP configuration information.

Configuring BGP service in an IPv6 environment

The following section goes through the steps required to configure the following BGP topology.



  1. Log in to the Address Manager server where the DNS/DHCP Server has been deployed as a service node.
  2. Select the Servers tab.
  3. Under Servers, click the name of the DNS/DHCP Server that the service node has been deployed to.
  4. Click the server name menu button and select Service Configuration.
  5. Under the Interface column, choose the loopback (lo) interface then navigate across the row to the Action column and click Edit.
  6. Complete the following:
    • In the Description field, enter a name for the new loopback address. You can enter up to 80 alphanumeric characters including spaces, but excluding special characters.
    • In the Address/CIDR field, enter 2001:200:1:f:10::1/128.
    • Click Add Address. The loopback address appears in the Addresses list.
  7. Click OK. The Edit Interfaces pop-up window closes.
  8. Log in to the Gateway instance that has the Distributed DDNS Application Node.
  9. Under AVAILABLE ACTIONS, click Distributed DDNS.
  10. Click the Service Points tab to access the service node page.
  11. Click Anycast service.
  12. Under the Configuration tab, select BGP.
  13. In the configuration window, enter the following information:
    !bgpd.conf
    !
    router bgp 200
    network 2001:db8:acad:a::1 remote-as 200
    !
    address-family ipv6
    network 2001:200:1:f:10::1/128
    neighbor 2001:db8:acad:a::1 active
    exit-address-family
    !
    log trap informational
    log stdout
    log file /var/log/quagga/bgpd.log
    log record-priority
    !
  14. Click Start to enable the BGP service.
  15. Click Save to save the BGP service configuration and add the service to the Distributed DDNS Service Node.
  16. Repeat steps 8 to 12 for the second service node, updating the ASN and IP address when updating the BGP configuration information.