Example FRRouting Anycast configuration - BlueCat Edge - Service Point v4.x.x

BlueCat Edge User Guide

Locale
English
Product name
BlueCat Edge
Version
Service Point v4.x.x

The following section displays example content from an FRRouting configuration file that is configured for OSPF and BGP anycast service. For more information on configuring FRRouting, refer to http://docs.frrouting.org/en/latest/setup.html.

Ensure that the Anycast VIPs are also added to the Anycast VIPs field when configuring Anycast service through the UI or added to the ipAddresses parameter when configuring Anycast service through the API.

Example OSPF configuration

!
! Zebra configuration
!
hostname ospf-test
password abc123
enable password abc123
log file /var/log/sdp/frr/frr.log
log syslog
!
interface eth0
 ip address 10.10.10.1/24
!
interface lo:1
 ip address 192.168.0.99/32
!
line vty
!
! OSPF configuration
!
hostname ospf-test
log file /var/log/sdp/frr/frr.log
log syslog 
!
router ospf
 ospf router-id 10.10.10.1
 log-adjacency-changes detail
 network 192.168.0.99/32 area 1
 network 10.10.10.0/24 area 0
!
line vty

Example BGP configuration

!
! Zebra configuration
!
hostname bgp-test
password abc123
enable password abc123
log file /var/log/sdp/frr/frr.log
log syslog
!
interface eth0
 ip address 10.10.10.1/24
 ipv6 nd suppress-ra
!
interface lo:1
 ip address 192.168.0.98/32
!
!--- Add as many 'interface' stanzas as required for anycast IP configuration.
!--- Below is an example of a second anycast IP definition.
! interface lo:2
!  ip address 192.168.0.99/32
!
line vty
!
! BGP configuration
!
hostname bgp-test
log file /var/log/sdp/frr/frr.log
log syslog
!
router bgp 65001
 bgp router-id 10.10.10.1
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 timers bgp 60 180
!
!--- Disable default policy that mandates incoming/outgoing filters.
 no bgp ebgp-requires-policy
!
 network 10.10.10.0/24
 network 192.168.0.98/32
!--- Specify as many /32 'network' statements as required for the number of anycast IPs.
!--- Below is an example of a 'network' statement for a second anycast IP.
! network 192.168.0.99/32
!
!--- Set up BGP neighbors here
 neighbor 10.10.20.1 remote-as 65002
 neighbor 10.10.20.1 ebgp-multihop 3
 neighbor 10.10.20.1 activate
!
line vty