Example FRRouting Anycast configuration - BlueCat DNS Edge

DNS Edge User Guide (Fleet Service Point)

Locale
English
Product name
BlueCat DNS Edge

The following section displays example content from an FRRouting configuration file that is configured for OSPF anycast service. For more information on configuring FRRouting, refer to http://docs.frrouting.org/en/latest/setup.html.

Each Anycast VIP must be created as a new sub interface under the Loopback (lo) interface starting with lo:1 for the first Anycast VIP, lo:2 for the second Anycast VIP, and lo:<n> for subsequent Anycast VIPs.

Ensure that the Anycast VIPs are also added to the Anycast VIPs field when configuring Anycast service through the UI or added to the ipAddresses parameter when configuring Anycast service through the API.

log stdout debug
#
hostname zebra-test
password abc123
enable password abc123
#
interface eth0
  ip address 10.10.10.1/24
interface lo:1
  ip address 192.168.0.99/32
#
# OSPF config
interface lo:1
  ip ospf priority 1
  ip ospf hello-interval 10
  ip ospf dead-interval 40
router ospf
  ospf router-id 10.10.10.1
  log-adjacency-changes
  router-info area
  network 10.10.10.0/24 area 1
  network 192.168.0.99/32 area 0
  redistribute connected
  distribute-list ANYCAST out connected

access-list ANYCAST permit 192.168.0.99/32