Using Python modules shipped with BlueCat Gateway - Platform - BlueCat Gateway - 22.4.1

Gateway Administration Guide

Locale
English (United States)
Product name
BlueCat Gateway
Version
22.4.1

Below is a list of Python libraries shipped with BlueCat Gateway v22.4.1 that follow BlueCat's standard deprecation policy:

  • Flask
  • Werkzeug
  • Jinja
  • MarkupSafe
  • WTForms
  • ItsDangerous
  • Requests
  • Flask-WTF
  • flask-mail
  • flask-pymongo
  • psycopg2
  • APScheduler
  • paramiko
  • persist-queue
  • PyYAML

You can import and use these libraries without having to install them. However, these modules might get updated to a newer version in future releases of BlueCat Gateway. If you use library functionality, you must always include a direct import statement in your workflow. Do not assume that libraries are automatically imported in any other modules you use. For example, if you want to use StringField directly in you code, you must include the corresponding import statement:

from wtforms import StringField

Other libraries shipped with BlueCat Gateway can be found in /portal/requirements.txt inside the Gateway image.

Note: These libraries are subject to change at any time and might be removed or replaced in a future version of Gateway.